Slow access or timeouts with Otera Studio

Incident Report for Otera

Resolved

All systems are fully operational.
Posted Mar 09, 2026 - 18:05 CET

Monitoring

Systems back to normal, we are currently monitoring.
Posted Mar 09, 2026 - 17:30 CET

Investigating

We are seeing issues with access to Otera Studio. Logins may take too long or fail. It is currently being worked on. Automations and execution are not affected.
Posted Mar 09, 2026 - 11:47 CET
This incident affected: EU (Studio Health - EU).